#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http(s)?:\/\/.)?(www\.)?(?:[-a-zA-Z0-9@:%_\+~#=]{1,63}\.)+[a-z]{2,6}\b((?:[-a-zA-Z0-9@:%_\+~#?&//="]+\.)*[-a-zA-Z0-9@:%_\+~#?&//="]+)?"
Local $sString = "asfd http://gskinner.co.im asfd" & @CRLF & _
"asfd m.skinner.com asfd" & @CRLF & _
"asfd www.gskinner.com asfd" & @CRLF & _
"asfd http://www.gskinner.com asfd" & @CRLF & _
"asfd www.gskinner.com?a=1&b=2 asfd" & @CRLF & _
"asfd gskinner.com?a="1"%203&b=2 asfd" & @CRLF & _
"asfd http://gskinner.com/a/b?c=3 asfd" & @CRLF & _
"asfd https://gskinner.com/a/b?c=3 asfd" & @CRLF & _
"asfd fdg.f.fg.gskinn.er.com/a/b?c=3 asfd" & @CRLF & _
"asfd ffgfgfgfgdfd/dfdfd.df asfd" & @CRLF & _
"asfd https://web.whatsapp.com/%F0%9F%8C%90/en asfd" & @CRLF & _
"asfd sdfsd://asdfw.asgd asfd" & @CRLF & _
"wealth.in..mutual sdf of 10k" & @CRLF & _
"wealth.Mutual,dfdfg sdf of 10k" & @CRLF & _
"wealth.Mutu/#index al of 10k" & @CRLF & _
"wealth.#MutualFundsSIP of 10k" & @CRLF & _
"wealth.$MutualFundsSIP of 10k" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")