import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http(s)?:\\/\\/.)?(www\\.)?(?:[-a-zA-Z0-9@:%_\\+~#=]{1,63}\\.)+[a-z]{2,6}\\b((?:[-a-zA-Z0-9@:%_\\+~#?&//=\"]+\\.)*[-a-zA-Z0-9@:%_\\+~#?&//=\"]+)?";
final String string = "asfd http://gskinner.co.im asfd\n"
+ "asfd m.skinner.com asfd\n"
+ "asfd www.gskinner.com asfd\n"
+ "asfd http://www.gskinner.com asfd\n"
+ "asfd www.gskinner.com?a=1&b=2 asfd\n"
+ "asfd gskinner.com?a=\"1\"%203&b=2 asfd\n"
+ "asfd http://gskinner.com/a/b?c=3 asfd\n"
+ "asfd https://gskinner.com/a/b?c=3 asfd\n"
+ "asfd fdg.f.fg.gskinn.er.com/a/b?c=3 asfd\n"
+ "asfd ffgfgfgfgdfd/dfdfd.df asfd\n"
+ "asfd https://web.whatsapp.com/%F0%9F%8C%90/en asfd\n"
+ "asfd sdfsd://asdfw.asgd asfd\n"
+ "wealth.in..mutual sdf of 10k\n"
+ "wealth.Mutual,dfdfg sdf of 10k\n"
+ "wealth.Mutu/#index al of 10k\n"
+ "wealth.#MutualFundsSIP of 10k\n"
+ "wealth.$MutualFundsSIP of 10k\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}