# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http(s)?:\/\/.)?(www\.)?(?:[-a-zA-Z0-9@:%_\+~#=]{1,63}\.)+[a-z]{2,6}\b((?:[-a-zA-Z0-9@:%_\+~#?&//=\"]+\.)*[-a-zA-Z0-9@:%_\+~#?&//=\"]+)?"
test_str = ("asfd http://gskinner.co.im asfd\n"
"asfd m.skinner.com asfd\n"
"asfd www.gskinner.com asfd\n"
"asfd http://www.gskinner.com asfd\n"
"asfd www.gskinner.com?a=1&b=2 asfd\n"
"asfd gskinner.com?a=\"1\"%203&b=2 asfd\n"
"asfd http://gskinner.com/a/b?c=3 asfd\n"
"asfd https://gskinner.com/a/b?c=3 asfd\n"
"asfd fdg.f.fg.gskinn.er.com/a/b?c=3 asfd\n"
"asfd ffgfgfgfgdfd/dfdfd.df asfd\n"
"asfd https://web.whatsapp.com/%F0%9F%8C%90/en asfd\n"
"asfd sdfsd://asdfw.asgd asfd\n"
"wealth.in..mutual sdf of 10k\n"
"wealth.Mutual,dfdfg sdf of 10k\n"
"wealth.Mutu/#index al of 10k\n"
"wealth.#MutualFundsSIP of 10k\n"
"wealth.$MutualFundsSIP of 10k\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.