using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"G\(([^,]+)(, ?([^),]+))*\)";
string input = @"not me G(select me, and me)
G(select me) G(also me)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}