import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n?\\d*?\\n?^.* --> [012345]{2}:.*$";
final String string = "1\n"
+ "00:00:04,019 --> 00:00:07,299\n"
+ "line1\n"
+ "line2\n\n"
+ "2\n"
+ "00:00:07,414 --> 00:00:09,155\n"
+ "line1\n\n"
+ "00:00:09,276 --> 00:00:11,429\n"
+ "line1\n\n"
+ "00:00:11,549 --> 00:00:14,874\n"
+ "line1\n"
+ "line2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}