$re = '/(?:[^_:]|(?<!_)_(?!_))+/';
$str = 'GT__abc23_1231:TF__XYZ451';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);