using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<day>[\d]*)(?:-|\/)(?<month>[\d]*)(?:-|\/)(?<year>[\d]*)$";
string input = @"10-10-2013
12/09/2013";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}