#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?=\.{1,2}\/|(?:[a-z]:)?[\\\/])"
Local $sString = "C:\hello world" & @CRLF & _
"test" & @CRLF & _
"/a/b/c" & @CRLF & _
"../x" & @CRLF & _
"./e" & @CRLF & _
"\\test\a\b" & @CRLF & _
"foobar" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")