using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\.{1,2}\/|(?:[a-z]:)?[\\\/])";
string input = @"C:\hello world
test
/a/b/c
../x
./e
\\test\a\b
foobar
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}