const regex = /^(?=\.{1,2}\/|(?:[a-z]:)?[\\\/])/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\.{1,2}\\\/|(?:[a-z]:)?[\\\\\\\/])', 'igm')
const str = `C:\\hello world
test
/a/b/c
../x
./e
\\\\test\\a\\b
foobar
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}