# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\w*-′]*([\[(]([\[(]?[a-zA-Zα-ωΑ-Ωµ\-′,:]+\d?[+-]?[\])]?)+[\])\d+-]{1,})[\w*-′]*)|(([A-z]+[a-z]*\d)+([A-z]+[a-z]*\d?)*)"
test_str = ("\"Fe(iii) or iron(iii) [Fe(Rtpen)X](A)n, n = 1, 2; X = Cl, Br; Rtpen = N-alkyl-N,N′,N′-tris(2-pyridylmethyl)ethane-1,2-diamine, alkyl = R = CH3CH2, CH3CH2CH2, HOCH2CH2, (CH3)2CH, C6H5, and C6H5CH2; A = ClO4, PF6.\"\n"
"\"iron(iii) \n"
"[Fe(Rtpen)(η1-OCH3)]2+ \n"
"[Fe(Rtpen)(η1-OOH)]2+ from iron(ii)\"\n"
"\"[FeIIIOOH]2+ rather than [FeIIIOO]+ species are the p\"\n"
"[(Rtpen)Fe(µ,η2:η2-O2)Fe(Rtpen)]4+\n"
"iron(iii)\n"
"Fe(iii)\n"
"[FeIIIOOH]2+\n"
"[Fe(Rtpen)Cl]+\n"
"[Fe(Rtpen)(η1-OOH)]2+\n"
"[Fe(Rtpen)X](A)n\n"
"[(Rtpen)Fe(µ,η2:η2-O2)Fe(Rtpen)]4+\n"
" Fe(Rtpen)(η2-OO)]+,\n"
"N′-tris(2-pyridylmethyl)ethane-1,2-diamine\n"
"of [Fe(Rtpen)(η1-OOH)]2+ pro\n"
" (ESR, UV-vis, ESI MS) \n"
" [Fe(Rtpen)(η1-OOH)]2+, R = CH3CH2, CH3CH2CH2, HOCH2CH2, (CH3)2CH, C6H5, and C6H5CH2.\n"
"f [Fe(ettpen)Cl]ClO4 instead of [Fe(bztpen)Cl]ClO4 \n"
"[Fe(Rtpen)Cl]A, A = ClO4, PF6, are as expected ESR silent.\n"
"[Fe(Rtpen)Cl](PF6) and [Fe(Rtpen)Cl](PF6)2\n"
"e µ-oxo complex [(bztpen)ClFe(µ-O)FeCl(bztpen)](PF6)2 which could be isolated.\n"
"H2O\n"
"[Fe(bztpen)Cl](ClO4)2\n"
" solution at 100 K, a rhombic low-spin signal (g = 2.32, 2.14, 1.93) is present in the spectra of the Fe(iii) complexes (Fig. 3a)\n"
").\n\n"
"metpen–Fe(iii)–peroxide complexes, lead to assignment of end-on coordination for the hydroperoxide species, e.g., [Fe(Rtpen)(η1-OOH)]2+, and side-on (η2) peroxide coordination in their deprotonated derivatives, e.g., [Fe(Rtpen)(η2-OO)]+ (Scheme 1)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.