#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "( )( )*([^ ])"
Local $sString = "abc def ghi xyz"
Local $sSubst = "$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)