using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( )( )*([^ ])";
string substitution = @"$2$3";
string input = @"abc def ghi xyz";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}