use strict;
my $str = 'abc def ghi xyz';
my $regex = qr/( )( )*([^ ])/p;
my $subst = '$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";