import re
regex = re.compile(r"( )( )*([^ ])")
test_str = "abc def ghi xyz"
subst = "$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)