$re = '/^(\/\w+)((\/\w+){3})\.(gif|jpg)/';
$str = '/hDfpiC4m4EnExfONLSlj2k6bkvw/lj/sn/0949bb8fd87f7b8762d001955d0d219b.png';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);