$re = '/(foo: ).*/';
$str = 'foo: bar';
$subst = "$1baz";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;