using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-zA-Z])(\n)";
string substitution = @"";
string input = @"Chapter 1
Lorem ipsum dolor sit amet, consectetur adipisci
ng elit, sed do eiusmod tempor incididunt ut la
bore et dolore magna aliqua. Ut enim ad minim ve
niam, quis nostrud exercitation ullamco labo ris
nisi ut aliquip ex ea commodo consequat.
Chapter 2
Lorem ipsum dolor sit amet, consectetur adipisci
ng elit, sed do eiusmod tempor incididunt ut la
bore et dolore magna aliqua. Ut enim ad minim ve
niam, quis nostrud exercitation ullamco labo ris
nisi ut aliquip ex ea commodo consequat.
Lorem ipsum dolor sit amet, consectetur adipisci
ng elit, sed do eiusmod tempor incididunt ut la
bore et dolore magna aliqua. Ut enim ad minim ve
niam, quis nostrud exercitation ullamco labo ris
nisi ut aliquip ex ea commodo consequat. ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}