import Foundation
let pattern = #"(?<=[a-zA-Z])(\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Chapter 1
Lorem ipsum dolor sit amet, consectetur adipisci
ng elit, sed do eiusmod tempor incididunt ut la
bore et dolore magna aliqua. Ut enim ad minim ve
niam, quis nostrud exercitation ullamco labo ris
nisi ut aliquip ex ea commodo consequat.
Chapter 2
Lorem ipsum dolor sit amet, consectetur adipisci
ng elit, sed do eiusmod tempor incididunt ut la
bore et dolore magna aliqua. Ut enim ad minim ve
niam, quis nostrud exercitation ullamco labo ris
nisi ut aliquip ex ea commodo consequat.
Lorem ipsum dolor sit amet, consectetur adipisci
ng elit, sed do eiusmod tempor incididunt ut la
bore et dolore magna aliqua. Ut enim ad minim ve
niam, quis nostrud exercitation ullamco labo ris
nisi ut aliquip ex ea commodo consequat.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)