re = /<(\S+).*?class="(?:\bschool\b.*?|.*?\bschool\b)".*?>(.+?)<\/\1>/m
str = '<h1 class="school">Primary</h1>
<h1 class="school project">Secondary</h1>
<h2 class="project school">Primary</h2>
<h2 class="project school">Primary</h5>
<h3 class="schools project">Secondary</h3>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end