re = /^\[0-9]\[0-9]\[0-9]\[0-9]\[0-9]\[0-9]\[0-9]\[0-9]\[0-9]\[0-9]$/
str = '0 542 246 99 22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end