const regex = /url\s*\(\s*[\'"]?(?!(((?:https?:)?\/\/)|(?:data\:?:)))([^\'"\)]+)[\'"]?\s*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('url\\s*\\(\\s*[\\\'"]?(?!(((?:https?:)?\\\/\\\/)|(?:data\\:?:)))([^\\\'"\\)]+)[\\\'"]?\\s*\\)', 'g')
const str = `#TEST {
background:url(test.jpg);
background:url( 'test.jpg' );
background:url("test.jpg" );
background:url(http://example.com/test.jpg);
background:url('https://example.com/test.jpg');
background:url("http://example.com/test.jpg");
background:url( '//example.com/test.jpg' );
background:url( "//example.com/test.jpg" );
background:url(//example.com/test.jpg);
}`;
const subst = `url("/themes/default/css/$3")`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);