$re = '/\s(?![\w!.]+"\s)/';
$str = 'print "Hello world!" out.txt
print"Hello world!"out.txt';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;