#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^"]*considerando|trabalho|social|providências|Réu:|Requerido:|Requerido\(s\):"
Local $sString = "CONSIDERANDO o poder constitucional conferido ao Ministério" & @CRLF & _
"Público de expedir notificação e requisições para instruir procedimentos" & @CRLF & _
"administrativos de sua competência;" & @CRLF & _
"CONSI2DERANDO que a Constituição Federal dispõe que "A" & @CRLF & _
"assistência social será prestada a quem dela necessitar, independentemente" & @CRLF & _
"de contribuição à. Requerido(s): seguridade social, e tem por objetivos: I - a" & @CRLF & _
"proteção à família, à maternidade, à infância, à adolescência e à velhice;" & @CRLF & _
"II - o amparo às crianças e adolescentes carentes; III - a promoção da" & @CRLF & _
"integração. Requerido: ao mercado de trabalho:" e" & @CRLF & _
"CONSI2DERANDO os elementos. Réu: contidos no Relatório de Auditoria" & @CRLF & _
"da Controladoria-Geral Réu: da União nos itens 5.1.1.; 5.1.2.; 5.1.3.;" & @CRLF & _
"5.1.6.; 5.1.7.; 5.1.8.; 5.1.10. 5.2.1.; 5.2.2.; 5.2.3.; 5.3.2.; 5.3.5. e 5.3.9;" & @CRLF & _
"(Ministério do. Réu: Desenvolvimento Social e combate à Fome)" & @CRLF & _
"RESOLVE:" & @CRLF & _
"INSTAURAR o presente PROCEDIMENTO PREPARATÓRIO" & @CRLF & _
"Nº 03/2015, objetivando apurar as irregularidades apontadas no Relatório" & @CRLF & _
"de Auditoria da Controladoria-Geral da União nos itens 5.1.1.; 5.1.2.; 5.1.3.;" & @CRLF & _
"5.1.6.; 5.1.7.; 5.1.8.; 5.1.10. 5.2.1.; 5.2.2.; 5.2.3.; 5.3.2.; 5.3.5. e 5.3.9;" & @CRLF & _
"determinando, desde já, que sejam adotadas as seguintes providências."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")