$re = '/^[A-Z][a-z]+\s[A-Z][a-z]+(?:[^"\']|"[^"]*"|\'[^\']*\')*?\b\d{10}$/m';
$str = 'Jennifer Ann from New York, "Wisdom" str, bl. 54, Ð’, with id 1234567890
Jennifer Ann" from New York, "Wisdom" str, bl. 54, Ð’, with id 1234567890';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;