import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/?Reference.*\\/?>";
final String string = "<Reference Include=\"Microsoft.AspNetCore.Sockets.Common.Http, Version=1.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60, processorArchitecture=MSIL\">\n"
+ " <HintPath>..\\..\\packages\\LIB.XPTO.1.18.524.20\\lib\\net45\\Microsoft.AspNetCore.Sockets.Common.Http.dll</HintPath>\n"
+ " </Reference>\n"
+ " <Reference Include=\"Microsoft.CSharp\" />\n"
+ " <Reference Include=\"Microsoft.Extensions.Configuration.Abstractions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60, processorArchitecture=MSIL\">\n"
+ " <HintPath>..\\..\\packages\\LIB.XPTO.1.0.1.2\\lib\\net45\\Microsoft.Extensions.Configuration.Abstractions.dll</HintPath>\n"
+ " </Reference>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}