package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(?:\.\d+)?`)
var str = `ghjkhjgbkhj123.45khgbkhjgk67 8kjhgkj hg13.99sads`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}