package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*/\d+-\d+-\d+-\d+m|.*/\d+-\d+-\d+-\d+`)
var str = `account_name/2015-12-01-001m
account_name/2015-12-01-001
account_name/2015-12-01-
account_name/2015-12-001`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}