#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<div class="listing-img-container media-cover text-center">[\s\S]*?src="([^"]+?\.jpg)"
Local $sString = "<div class="panel-image listing-img">" & @CRLF & _
" <a href="/rooms/854260?s=BD20" class="media-photo media-cover">" & @CRLF & _
" <div class="listing-img-container media-cover text-center">" & @CRLF & _
" <img itemprop="image" data-current="0" src="https://a2.muscache.com/ic/pictures/19208233/4d8e6c0d_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70"" & @CRLF & _
" class="img-responsive-height" alt="Cozy room - Prague centre Old Town" data-urls="[output-format=jpg&output-quality=70", "https://a1.mu "ut-format=jpg&output-quality=70"]">" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")