import re
regex = re.compile(r"^([^\x00-\x7F]|[\w_\ \.\+\-]){2,16}$")
test_str = "MartBuča1as_sass"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")