using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(src="")(.*"")";
string substitution = @"$1domain.com/$2";
string input = @"<img src=""uploads/1.jpg""> Привет <img src=""uploads/2.gif"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}