use strict;
my $str = '<img src="uploads/1.jpg"> Привет <img src="uploads/2.gif">';
my $regex = qr/(src=")(.*")/p;
my $subst = '$1domain.com/$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";