import Foundation
let pattern = #"\([0-9]{2}\) 9?[0-9]{4}-[0-9]{4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(11) 33333321
(11) 8543-0897
(11) 99076-1345
(11) 9046 -1345
(11) 2450 -5678
(11) 9764-4356
(11) 99991111
(11) 58753201
(11) 67890431
(11) 999999999
(11) 78906542
(11) 83567031
(11) 09853212
(11) 45678901
(11) 23456790
(11) 4004-1000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)