const regex = /\([0-9]{2}\) (?:9[0-9]{1}|[1-5]{1})[0-9]{3}-[0-9]{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([0-9]{2}\\) (?:9[0-9]{1}|[1-5]{1})[0-9]{3}-[0-9]{4}', 'gm')
const str = `(11) 33333321
(11) 8543-0897
(11) 99076-1345
(11) 9046 -1345
(11) 2450 -5678
(11) 9764-4356
(11) 99991111
(11) 58753201
(11) 67890431
(11) 999999999
(11) 78906542
(11) 83567031
(11) 09853212
(11) 45678901
(11) 23456790
(11) 4004-1000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}