const regex = /^\(*\d{2}\)*\s*[6|7|8|9](?:\d{7}|\d{3}\s*-\s*\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\(*\\d{2}\\)*\\s*[6|7|8|9](?:\\d{7}|\\d{3}\\s*-\\s*\\d{4})$', 'gm')
const str = `1133333321
41 8543-0897
119076-1345
(21)9046 -1345
2450 -5678
9764-4356
2199991111
(51)58753201
(57)67890431
999999999
78906542
83567031
09853212
45678901
23456790
40041000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}