$re = '/^[0\.]+/m';
$str = '0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);