#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^#([A-Z]):\s"
Local $sString = "Ludus øfficiis suåvitate sea in, ius utinam vivendum no, mei nostrud necessitatibus te? " & @CRLF & _
"" & @CRLF & _
"#A: This is some info." & @CRLF & _
"#B: Some more info." & @CRLF & _
"#C: More stuff." & @CRLF & _
"#A: The end." & @CRLF & _
"" & @CRLF & _
"Lørem ipsum dolør sit amet, eu ipsum movet vix, veniam låoreet posidonium te eøs, eæm in veri eirmod."
Local $sSubst = "$1:] "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)