using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#([A-Z]):\s";
string substitution = @"$1:] ";
string input = @"Ludus øfficiis suåvitate sea in, ius utinam vivendum no, mei nostrud necessitatibus te?
#A: This is some info.
#B: Some more info.
#C: More stuff.
#A: The end.
Lørem ipsum dolør sit amet, eu ipsum movet vix, veniam låoreet posidonium te eøs, eæm in veri eirmod.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}