use strict;
my $str = 'Ludus øfficiis suåvitate sea in, ius utinam vivendum no, mei nostrud necessitatibus te?
#A: This is some info.
#B: Some more info.
#C: More stuff.
#A: The end.
Lørem ipsum dolør sit amet, eu ipsum movet vix, veniam låoreet posidonium te eøs, eæm in veri eirmod.';
my $regex = qr/^#([A-Z]):\s/mp;
my $subst = '$1:] ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";