const regex = /1[5-9]\d{2,}|[2-9]\d{3,}|1\d{4,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('1[5-9]\\d{2,}|[2-9]\\d{3,}|1\\d{4,}', 'g')
const str = `800
0800
1234
1511
1555
1789
2111
2345
3456
56756
123123
123123123
159999999999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}