use strict;
my $str = '800
0800
1234
1511
1555
1789
2111
2345
3456
56756
123123
123123123
159999999999';
my $regex = qr/1[5-9]\d{2,}|[2-9]\d{3,}|1\d{4,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}