re = /1[5-9]\d{2,}|[2-9]\d{3,}|1\d{4,}/
str = '800
0800
1234
1511
1555
1789
2111
2345
3456
56756
123123
123123123
159999999999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end