$re = '/li>(.*?)(?:<\/li)/m';
$str = '***some text*** li> ***data to capture***</li ***more text***';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);