package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\*([\s\S]*)?\*\/`)
var str = `/* This is a comment
/* This is another comment */`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}