// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)((ftp|https?):\/\/|(www\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\S*[^\s.;,(){}<>"\u201d\u2019]"#).unwrap();
let string = "\"{\\\"value\\\": \"https://example.com/path\\\"},{\\\"foo\\\":\\\"{‡€°\"‹Ó}\\\",\\\"bar\\\":null\"}\"
^ ^
it should have stopped here special chars shouldn't match";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}