using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"nt[ {2}]\b";
string input = @"nt1 nt2 nt2bfsdf nt3 nt4 nt5 xxnt6 xxnt7 nt8";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}