const regex = /<textarea>((?:(?!<\/textarea>).)*?)ccc(.*?)<\/textarea>
/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<textarea>((?:(?!<\\\/textarea>).)*?)ccc(.*?)<\\\/textarea>
', 's')
const str = `<textarea>asdasdasdasd as</textarea>
<textarea>asdacccda
sdas</textarea>
<textarea>asdasdasdasd as</textarea>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}