using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?<!^)(?<![.?!] )[A-Z][A-Za-z]*";
string input = @"Now is the Time.
For all good Rubyists? To come to the aid of their Bowling team. ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}