using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<state>\S+)\s+(?P<connectivity>\S+)\s+(?P<wifi_hw>\S+)\s+(?P<wifi>\S+)\s+(?P<wwan_hw>\S+)\s+(?P<wwan>\S+)(?:\s+(?P<metered>.+)?)?$";
string input = @"connected full enabled enabled missing enabled no (guessed)
unknown none enabled enabled enabled disabled";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}