package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<state>\S+)\s+(?P<connectivity>\S+)\s+(?P<wifi_hw>\S+)\s+(?P<wifi>\S+)\s+(?P<wwan_hw>\S+)\s+(?P<wwan>\S+)(?:\s+(?P<metered>.+)?)?$`)
var str = `connected full enabled enabled missing enabled no (guessed)
unknown none enabled enabled enabled disabled`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}